Browser extension update: version 2.2.3

It has been a while since the last major update of Adguard browser extension, but a few days ago we did it! We released the new version of our extensions. This release contains one important change for the Firefox version and some technical features with our selector library.

Optimization for multiprocess Firefox #138

This is the main feature of the release. As you may heard, Firefox browser is switching to the multiprocess model. To ensure our add-on will work correctly we had to adjust and move to a different API. PageMod we were using previously would seriously limit us in implementing new important features in future Firefox extension releases. To avoid this, we switched to frame-scripts API instead of PageMod. It is important no mention that this change will also improve overall performance for Firefox extension users.

Firefox

[Added] “useGlobalStylesheet” option added to Firefox about:config #163
[Fixed] Compatibility issue with Random Agent Spoofer add-on #174
[Fixed] Filters update notification pops up correctly now #192
[Fixed] User filter export works correctly now #193

Chromium

[Fixed] “Block ads on this site” button now works as intended if several windows are opened #134

Other changes

[Changed] “Selector” module code refactoring and creating an independent module from it #55
This issue is more technical and for now will not immediately affect end-user experience. But that means we are now able to make changes relating to element blocker tool faster and easier, as well as reuse the code in our other products, such as AG Assistant and mobile apps. For example, in the next release you will see redesigned element blocker tool interface.
[Fixed] Selector lib creates an invalid rule #133

How to install Adguard extension

Stable version

Chromium
* Chrome Store

Firefox (version 38 or newer)
* Addons.mozilla.org

Safari
* Safari Extensions Gallery
* Standalone safariextz file

Opera
* Addons.opera.com

Beta version

If you want to help us with Adguard development, you can install the beta version of Adguard.

Chromium
* Chrome Store

Firefox (version 38 or newer)
* Addons.mozilla.org
* Standalone xpi

Old firefox versions (includes Palemoon)
* Standalone xpi

Safari
* Standalone safariextz file
Important note: beta version of Adguard extension is updated from our server. In Safari 9+ such updates cannot be applied automatically, you should check “Safari” -> “Extensions” from time to time.

Mr. Adguard

Wow... you got us! We really can't remember who wrote this article... So, here I am - Mr. Adguard tidying up after someone else.

Subscribe to Adguard Blog

Get the latest posts delivered right to your inbox.

or subscribe via RSS with Feedly!